Search results

  1. Oxyacetylene

    Water Pump Leak, small crack in rear of housing

    I'll check through that thread. I vaguely remember when that happened to you. I didn't mention it above, but the outside bolt that mounts the alternator is missing on mine, so alternator rests inwards a little. That may have contributed to it. Good 'ole expedient fix done by the gov't I guess. I...
  2. Oxyacetylene

    Water Pump Leak, small crack in rear of housing

    OK thank you! Yeah maybe I'll look at welding it up. Good preheat and slow cooling and it might do OK. Now just a matter of finding time to fix it.
  3. Oxyacetylene

    Water Pump Leak, small crack in rear of housing

    Hmm, tempted to just leave my belt as is for now. It's not cracked, but it's at least 5 years old at this point. Link me to your thread if you have it handy? I'll keep digging through search results if not.
  4. Oxyacetylene

    Water Pump Leak, small crack in rear of housing

    Ah OK, good to know the cheap aftermarket variety will not work. I haven't taken mine off yet, but I see it has two numbers on the back housing: one for "with hole" and one for "without hole." I'm wondering if that is the difference. I can't read the numbers without taking it off. Yours is...
  5. Oxyacetylene

    Water Pump Leak, small crack in rear of housing

    I recently used my truck to pull an equipment trailer and tractor on a couple hour trip. On the way back I stopped and noticed it was dripping coolant. Bought some at the gas station and filled the overflow tank between the sight glasses. Within the next 2 hours it had leaked all of that out...
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks