• Steel Soldiers now has a few new forums, read more about it at: New Munitions Forums!

  • Microsoft MSN, Live, Hotmail, Outlook email users may not be receiving emails. We are working to resolve this issue. Please add support@steelsoldiers.com to your trusted contacts.

 

JLTV 1278 questions

Mekanik

New member
6
2
3
Location
Ohio
I’m not too sure on where to post this thread because I couldn’t find any sections for a 1278 so if I’m in the wrong spot I apologize.
Anyways I have a 1278 JLTV in my bay that was brought in for a wiring harness due to a couple of codes being thrown on the DSDU. It did not run when it was brought in, we thought it would after replacing the harness. That did not work, there are no longer any codes on the dsdu. I follow the TM for engine crank but no start and it tells me to replace the engine. There are only 176 miles on this vehicle, is it possible the engine is no good? Is there switches on the inside or outside of the cab that I’m not seeing? It is not in tow mode and the manual fuel priming pump is in run mode. When I do turn it over it tries to start but does nothing I get a little smoke out of the exhaust. I’ve cracked the injector lines to make sure I’m getting fuel there which I am. I have drained the fuel tank and put new fuel in it still the same result. Any help will be appreciated.
 

DeMilitarized

Well-known member
312
880
93
Location
Gainesville, GA
Need to test actual fuel rail/ line pressure to see if it meets the proper pressure spec for the engine that is in the vehicle. If the pressure is too low then a pickup tube could be clogged or a line or the injection pump be bad. Also it could cause the injectors to not fire properly on some cylinders.
 

GeneralDisorder

Well-known member
Steel Soldiers Supporter
1,360
3,839
113
Location
Portland, OR
Give it a whiff of ether and see if it kicks off for a second - make sure it's a very small amount. If it does then chances are there's some computer lockout or wiring issue that's not enabling the fueling.

I'm no expert on the JLTV.

Also I have to say - having looked over a JLVT - WAY too complex. PVT Snuffy going to hit the wrong button and eject the warp core. o_O
 

Mekanik

New member
6
2
3
Location
Ohio
I’ve checked the fuel pressure at the rail it’s good, I also tried to use ether and it’ll run for about 3 seconds then shut down. I’m assuming it is a wiring issue and as much as I don’t want to I’m ordering a main engine wiring harness for it, once it comes in and I replace it I’ll post an update. Thank you guys for your help
 

Sixgun_Symphony

New member
1
0
1
Location
Colorado
Any updates?

I try to reach out to guys that might have been working around the new trucks. If I can ask, what are your impressions on the truck? ... I'm ex-Army here (11B, 1-5CAV, and 2-8INF), got out in 2012... Iraq 06 again in 09 and then Afghanistan '11... I got to work with the Oshkosh MATV a lot there, I've been following the development of the JLTV and am mildly obsessed with it now lol... Wish I could have played around with it or still had access to the nerdy technical stuff. I've heard both really good things about it, and some not-so-good things. Still wish we would have had this earlier in the GWOT
 
Last edited:
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks