New top and curtain! Top doesn't fit the bows, though!

Edis06

Active member
104
38
28
Location
Florida
I just installed my new top and curtain. The top fits snug, however the forward and aft bows don't line up with the reinforced strip and velcro. Now that the bow isn't aligned, the wind raises the top a bit and pulls at the velcro at an angle and it's starting to tear!

The bows and rails are in perfect shape and are straight, however the top itself doesn't line up. In fact, in the photo you can see that the lock/snap at the bow juncture lines up perfectly with the hole in the top, however the reinforced stripe is off! Odd.

Anyway, is it possible that there was a newer model of bow/rail combo for which this top might fit? If not, then I need to modify the bow with a second bar that does line up to prevent further damage.

Also, for the record the front bow sits too far forward and the rear bow sits too far back. The middle B-pillar is aligned as expected.
 

Attachments

knighthawkgamer

New member
28
6
3
Location
Corona, CA
Have you tried switching the side bars sides? I have heard people that have problems with things lining up say that the side rails are specific to one side. So if they are on the wrong side things do not line up.
 

Edis06

Active member
104
38
28
Location
Florida
Have you tried switching the side bars sides? I have heard people that have problems with things lining up say that the side rails are specific to one side. So if they are on the wrong side things do not line up.
Problem is if I did that and it properly aligns the bow, then the hole in the top won't line up! The hole should be in direct alignment with the reinforced stripe, otherwise one of the two won't match. I'm stumped.
 

Action

Well-known member
2,272
175
63
Location
East Tennessee
AFTER you have the rails on the correct sides, you can loosen the single phillips screw at each end of the bows. This may allow the bow to move a bit. Secure velcro. Then tighten screws back down. You may have to unhook the top from the handrails to see the screws.
 

Edis06

Active member
104
38
28
Location
Florida
AFTER you have the rails on the correct sides, you can loosen the single phillips screw at each end of the bows. This may allow the bow to move a bit. Secure velcro. Then tighten screws back down. You may have to unhook the top from the handrails to see the screws.
That's going to be my only option, unless I weld a separate bar to connect the top properly. Loosening the bow will allow it to rotate and lean in the right direction but it's hardly a professional fix. My old top fit snug and the velcro/reinforced stripe was in perfect alignment with the snap. This thing is off by 1.5-2". When I move the rails then the snap no longer lines up.
 

Edis06

Active member
104
38
28
Location
Florida
After a day of driving, I can already see a small pinhole, suggesting this will leak right on my head. My old top didn't leak at least - might just toss this thing. Wasted another $1K.

Also, after a close inspection, you can clearly see that the quality is terrible compared with my original. None of the seams are straight. The reinforced stripes are all crooked, including the ones that run front to back - they only follow the seams part way then they veer off course lol. Total trash.
 

owensexport

Member
62
2
8
Location
Chatsworth, CA
Also, after a close inspection, you can clearly see that the quality is terrible compared with my original. None of the seams are straight. The reinforced stripes are all crooked, including the ones that run front to back - they only follow the seams part way then they veer off course lol. Total trash.

Is it a GMA surplus top or a new Breton top?
 

Edis06

Active member
104
38
28
Location
Florida
Is it a GMA surplus top or a new Breton top?
IDK, this came from SECO along with all the other junk I've ordered from them. The "refurbished and refinished" wheels just arrived for $600.00, Trash. Spraypainted right over the CARC. I specifically told them don't place the order if they're not sandblasted and refinished. They sent me a close up of one wheel that turned out good. The other three are GARBAGE. Total garbage. My old ones look much better.
 

BKubu

Well-known member
Steel Soldiers Supporter
4,396
198
63
Location
Gaithersburg, MD
It could just be a factory flaw. I once bought a brand new M939 series hard top (from another vendor). I removed it from an unopened crate. Well, it did not fit right. The fabrication of the front piece that butts up against the A pillar was crooked. The fabricated part had to be cut to allow the top to sit down properly. Once we finished, you couldn't really see the fix. I only am pointing this out because the top could have been made incorrectly. In that case, it is NOT SECO's fault, but I'd expect them to stand behind the merchandise they sold and give you another top. Or, tell them you want to return it because it is defective. How long have you had it?
 

Crapgame

Active member
488
89
28
Location
Navarre, FL
I think both Wolfer and Seco may carry some parts made in Asia. Possible you were shipped a Chinese-mfg top that is out of spec. Wouldn't be the first time a US company paid a Chinese company to replicate a US part, the samples arrive in the US exact copy but when the production parts arrive half or all are not to spec.
 

owensexport

Member
62
2
8
Location
Chatsworth, CA
IDK, this came from SECO along with all the other junk I've ordered from them. The "refurbished and refinished" wheels just arrived for $600.00, Trash. Spraypainted right over the CARC. I specifically told them don't place the order if they're not sandblasted and refinished. They sent me a close up of one wheel that turned out good. The other three are GARBAGE. Total garbage. My old ones look much better.
Sounds about right!!
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks