Pulling/Rebuilding Injection Pump.... Having doubt

Dasgog

Member
80
25
18
Location
Tucson, AZ
Hello!

So after looking over everything else and finding nothing to explain my diesel in my oil and rising dipstick I have come to the conclusion (with advice) that the seal/s in my HH,Fuel Cut off and or Booster Pump is to blame. I’ve decided to just rebuild it.
I have indeed read and printed the pages pertaining to the “replacing of the IP”.
From what I gather;
Remove all 6 steel fuel lines and all lines/hoses connecting to and from the IP. Including the oil hose.
Remove top plate and turn engine manually til it times right and I see the white mark on the IP as well as the red tooth on the shut off.
Take off front plate and the bolt/gear.
Make sure back end (towards firewall) is disconnected from the block.
How many/ what bolts hold it ON? There’s 2 at the front end then the long long one from behind, so 3?
Is this gonna fall on me should I tie it so it doesn’t.. what am I missing I feel I am missing.
 

NY Tom

Well-known member
Steel Soldiers Supporter
340
336
63
Location
Riverhead, NY
I don't think you need to pull the entire pump out to solve your problem.

You can do the three O-Rings in the head without a whole lot of hassle. Just pull the 6 hard lines off, remove the shutoff cover, line up the red pointer, it all should come out easily. Clean it up, change the O-Rings, put it back and done.

Booster pump will require some messing around but it can be done with the pump on the truck. Threads explain how to pull the engine to the side to gain access.
 

Dasgog

Member
80
25
18
Location
Tucson, AZ
I don't think you need to pull the entire pump out to solve your problem.

You can do the three O-Rings in the head without a whole lot of hassle. Just pull the 6 hard lines off, remove the shutoff cover, line up the red pointer, it all should come out easily. Clean it up, change the O-Rings, put it back and done.

Booster pump will require some messing around but it can be done with the pump on the truck. Threads explain how to pull the engine to the side to gain access.
hello!

well before this response I had order a complete IP/HH/Booster Rebuild so I am definitely taking it all out.
As a matter of fact;

Every line incoming and outgoing is off.
All 5 bolts in the front are off and cover plate is off.
The 3 bolts and the gear is off.
The 2 bolts are off that connect the other end to the engine .
The 3 bolts on the inner side connecting the IP to the housing are off.

And yet... it wobbles but is not coming off!

does this need to come off too????
 

Attachments

Dasgog

Member
80
25
18
Location
Tucson, AZ
Center nut no.
Then I am confused!! All bolts are off even the ones not needed. When I push and pull it is loose but feels like on the bottom end towards block it’s connected somehow but there are no more bolts.
maybe after work I’ll have a fresh outlook and see something else I missed.
 

M37M35

Well-known member
Steel Soldiers Supporter
466
426
63
Location
East Central Oklahoma
When I push and pull it is loose but feels like on the bottom end towards block it’s connected somehow but there are no more bolts.
Did you unhook the small oil feed line that's between the pump and block? You should also replace those two lines while you're at it.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks