84 1008 build.

linemech31

Active member
90
107
33
Location
New Hampshire
Deleted the brush guard. Lots to do still. I know ill get flack by the traditionalists but i think i will head towards a more civilian look. Glossy paint etc...
 
Last edited by a moderator:

linemech31

Active member
90
107
33
Location
New Hampshire
Cleaning up more electrical stuff. I used good environmental heat shrink type connectors. Also not in the pics was an issue with the coolant sensor on the right side of the radiator. That wire had completely chafed through.
 

Attachments

51
23
8
Location
Tallahassee FL
I had a 88 V30 Air Force truck that was a 6.2 and the sensor for the high idle in the passenger side of the engine shorted out internally causing it not to work. It that also killed all my dash gauges as well. Not sure if it causes your dash to do the same as it’s lights only. It’s a fairly big 2 prong sensor on the passenger side kinda toward the rear if Its the same as my 88 was. May not be though. Be prepared to lose coolant and at that time only GM carried it and it was expensive. But that was 5 years ago.
 

dougco1

Active member
661
186
43
Location
Cooperstown NY
I had a 88 V30 Air Force truck that was a 6.2 and the sensor for the high idle in the passenger side of the engine shorted out internally causing it not to work. It that also killed all my dash gauges as well. Not sure if it causes your dash to do the same as it’s lights only. It’s a fairly big 2 prong sensor on the passenger side kinda toward the rear if Its the same as my 88 was. May not be though. Be prepared to lose coolant and at that time only GM carried it and it was expensive. But that was 5 years ago.
https://www.amazon.com/dp/B000C9D1SW/?tag=jhdiesel-20

https://www.rockauto.com/en/parts/acdelco,10154649,cold+advance+solenoid+connector,1000346
 
Last edited:

NDT

Well-known member
Steel Soldiers Supporter
8,412
1,132
113
Location
Camp Wood/LC, TX
For your frame use Sherwin Williams Kem Lustral F65B50 Wrought Iron Flat Black. Matches factory exactly.
 

dougco1

Active member
661
186
43
Location
Cooperstown NY
I used sem rust trap. Paint guy said it was satin. Its pretty glossy. But ill have it undercoated with oil when i am done. So it really doesn't matter.
It says on the can you pictured in post 32 "gloss black". Never trust a "Paint Guy". Looking good though. Nice to see another one being saved.
 

linemech31

Active member
90
107
33
Location
New Hampshire
Ive got a little drama. I am missing part of the rear wiring harness. I have the flat 6 pin connector coming from the cab which mounts to the rear of the frame. I am missing from that flat 6 pin towards the tail lights. Does anyone have a link where i can get that?
 

Matt S

Member
Steel Soldiers Supporter
124
20
18
Location
Los Angeles, CA
You're making me look bad! I'm a year in and still have a rusty rear frame in the back waiting to be wired and sprayed.

Nice work!
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks