What have you done to your FMTV or LMTV today

Steel Soldiers is supported by:

fuzzytoaster

Well-known member
Steel Soldiers Supporter
3,603
268
83
Location
Fort Worth, Texas
BUMP! I got in my new-to-me M1078A1. I took a gamble on a non-runner from a local source. It came out of the 3-1 Assault Helicopter Battalion from Knox shows the log book. Last date was 06 June 16 so it's a fairly recent release from service. Even the annual service was due 4/13/17 which makes me feel better about it not sitting around. The log shows all "Go" marks except for one tail light in-op. I had the truck hauled home to be on the safe side both due to safety and the likely trouble with an A1. The batteries were dead, had a full tank of fuel but no prime (typical bad primer), and found the cab's hydraulic jack leak too. Luckily the wrecker came in handy after a little priming for the safety latch to release. After a quick prime and slave she turned over but no-start. I'll be getting back after the holiday to plug in a diagnostic reader to see what's up. By then I'll have fresh (or recovered) batteries for it among other things. My helper learned a thing or two too. :mrgreen:
 

Attachments

Crapgame

Active member
454
66
28
Location
Navarre, FL
Got a used Mk93 Soft Mount for the M2HB in today for Animal Muthah, going to have it media blasted, repainted and repark the hardware.
 

Crapgame

Active member
454
66
28
Location
Navarre, FL
I attempted to swap out the hyd/pneu manifold this evening (Will sent me a nice one!, both labels nice shape), I swear this beech fought me the whole way, 3hrs later, No Joy, got dark before I could finish and I was afraid to cross thread the pipe fittings so I quit for the day,

The driver's door glass is partially in, it won't slide all the way down I think I have to loosen the two brackets that hold the channel in place, crank it down until it opens the channel enough to fit, hand tighten get the glass out of the way then torque down.

My truck is missing the inside window seal piece, and I have to replace both the door seals themselves.

Everything is just taking me 5x as long as I had planned, I don't think I'm going to make it for the May 12th Veterans Appreciation in the park here.
 

Coffey1

Well-known member
Steel Soldiers Supporter
3,775
250
83
Location
Gray Court SC
Mine the fan blade came loose on the way home from Denton.
Towed it to Andy's and took it apart and bolted hub to fan reinstalled working great.
So glad it didn't tear anything up.
 

KGBruce

New member
39
0
0
Location
High Ridge, MO
Boy! I can't wait to do something fun like you guys do with your trucks! If I can ever get my WTEC111 shift selector to wake up!! I think I need some advice. I have followed the diagnostics and it precisely concludes my shift selector is bad. I purchased another one that was a known working unit and it will not illuminate either. I have 24 V when and where I should and I have all of the grounds confirmed (battery, chassis and digital ground) I have confirmed power and grounds at the ECU and at the PX33 connector. All CB's and relays function and TB1 and TB2 check out. Anybody ever have a shift selector that just won't illuminate?
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks